Posts

Showing posts from December, 2023

Mark an app as secure to run on Mac on command line

 sudo xattr -r -d com.apple.quarantine /Applications/Theapp.app 

How to format/partition a disk from the command line

 diskutil partitionDisk /dev/disk3 GPT jhfs+ foo 10g jhfs+ bar 10g

Boot MacOS under VirtualBox

  Introduction The following steps are needed to boot Mac OS under VirtualBox. I tested it using Mac OS X 10.13. I can't guarantee this works. You'll need a source/original mac to copy the OS install. Probably Apple won't approve of this because they want you to buy their original hardware, but sometimes you need hosted VMs in the cloud or similar, and they don't really offer that. You can see this page for more:  https://johnsmactips.blogspot.com/2021/02/managing-virtualbox-on-command-line.html Steps Commands below are typed in a command line like the Terminal. 1. On a Mac, do this to download an installer disk: softwareupdate --fetch-full-installer --full-installer-version  ... OR download from the app store. If the operating system you want to install is out of date, ie if the Mac tells you the installer is damaged, set your Mac date and time to however many years ago that operating system came out, and turn of automatic date and time in the date and time system pref